Skip to main content

 路由器设置 > 新闻资讯 >

默认路由全解析

2012-06-10 23:45 浏览:

默认路由:百度百科给出的定义,默认路由是一种特殊的静态路由,指的是当路由表中与包的目的地址之间没有匹配的表项时路由器能够做出的选择。默认路由的使用可以大大节省系统资源,缩减路由表的大小。

产生默认路由的方法:

ip route 0.0.0.0 0.0.0.0 : 在路由功能开启的情况下,通过该命令可以为路由器配置默认网关

ip default-gateway:当路由器上的ip routing无效时,使用它指定默认路由,用于RXboot模式(no ip routing)下安装IOS等,或者关闭ip routing让路由器当主机用,此时需要配置默认网关。另外此命令常用于二层交换机上,因为在二层交换机上没有第三层路由表项。

ip default-network:用于路由模式下,会自动被动态路由协议传递给邻居。

同时使用ip default-network和ip route 0.0.0.0 0.0.0.0 双方设定默认路由时,如果ip default-netwok设定的网络是直连(静态、且已知)的,那么它就成为默认路由;如果ip default-network指定的网络由交换路由信息得来的,则ip route 0.0.0.0 0.0.0.0指定的表项成为默认路由。

default-information originate:在动态路由协议中发布默认路由。

 默认路由

利用静态路由实现全网互通,且R4只能配置一条静态路由。

R1 
hostname R1 
interface Loopback0 
ip address 1.1.1.1 255.255.255.0 
interface Loopback1 
ip address 12.0.0.1 255.255.255.0 

interface FastEthernet0/0 
ip address 12.12.12.1 255.255.255.0 
interface FastEthernet1/0 
ip address 13.13.13.1 255.255.255.0 
interface Serial2/0 
ip address 14.14.14.1 255.255.255.0 
clock rate 64000 

配置静态路由: 
ip default-network 12.0.0.0 
ip route 2.2.2.0 255.255.255.0 12.12.12.2 
ip route 3.3.3.0 255.255.255.0 13.13.13.3 
ip route 4.4.4.0 255.255.255.0 14.14.14.0 
ip route 23.23.23.0 255.255.255.0 12.12.12.2 
ip route 200.1.1.0 255.255.255.0 12.12.12.2  

R2和R3的配置类似于R1

R4:

hostname R4
interface Loopback0 
ip address 4.4.4.4 255.255.255.0 

interface Serial2/0 
ip address 14.14.14.4 255.255.255.0 
ip route 0.0.0.0 0.0.0.0 14.14.14.1      配置一条默认路由,实现网络连通

出处:http://domyself.blog.51cto.com/2917805/894531