Skip to main content

 路由器网 > 新闻资讯 >

如何将路由器封装成帧中继

2014-06-16 00:21 浏览:

在学习OSPF的时候会使用到帧中继,那如何将路由器当帧中继网络来使用呢?下面帖上一篇配置和介绍给大家看看。模拟环境拓扑如下图:

wKioL1OdKs6jPke7AACmznRiYKc347.jpg

 

FR:

 

Building configuration...

 

Current configuration : 1632 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname FR

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

ip domain name lab.local

!         

frame-relay switching                                           //开启帧中继

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!         

archive

 log config

  hidekeys

!

!

!

!

!

!

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/0

 no ip address

 shutdown

 clock rate 2000000

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/1

 no ip address

 encapsulation frame-relay                              //封装类型为帧中继

 clock rate 2000000

 frame-relay lmi-type cisco                             //CISCO协议

 frame-relay intf-type dce                              //帧中继接口类型为DCE

 frame-relay route 102 interface Serial0/2 201

 frame-relay route 103 interface Serial0/3 301

!

interface Serial0/2

 no ip address

 encapsulation frame-relay

 clock rate 2000000

 frame-relay lmi-type cisco

 frame-relay intf-type dce

 frame-relay route 201 interface Serial0/1 102

 frame-relay route 203 interface Serial0/3 302

!         

interface Serial0/3

 no ip address

 encapsulation frame-relay

 clock rate 2000000

 frame-relay lmi-type cisco

 frame-relay intf-type dce

 frame-relay route 301 interface Serial0/1 103

 frame-relay route 302 interface Serial0/2 203

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!         

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

!

end

 

 

 

 

主要是介绍上面的,下面帖也一下R1、R2、R3的配置可供参考

R1:

Current configuration : 1366 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

ip domain name lab.local

!         

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive   

 log config

  hidekeys

!

!

!

!

!

!

!

interface Loopback0

 ip address 172.16.1.1 255.255.255.0

 ip ospf network point-to-point

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 192.168.1.1 255.255.255.0

 encapsulation frame-relay

 ip ospf network broadcast

 clock rate 2000000

 frame-relay map ip 192.168.1.3 103 broadcast

 frame-relay map ip 192.168.1.2 102 broadcast

 no frame-relay inverse-arp

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/1

 no ip address

 shutdown

 clock rate 2000000

!

router ospf 1

 log-adjacency-changes

 network 172.16.1.1 0.0.0.0 area 0

 network 192.168.1.1 0.0.0.0 area 0

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

!

end

 

R2:

Building configuration...

 

Current configuration : 1294 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

ip domain name lab.local

!         

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive   

 log config

  hidekeys

!

!

!

!

!

!

!

interface Loopback0

 ip address 172.16.3.1 255.255.255.0

 ip ospf network point-to-point

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 192.168.1.2 255.255.255.0

 encapsulation frame-relay

 ip ospf network broadcast

 ip ospf priority 0

 clock rate 2000000

 no frame-relay inverse-arp

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/1

 no ip address

 shutdown

 clock rate 2000000

!

router ospf 1

 log-adjacency-changes

 network 172.16.3.1 0.0.0.0 area 0

 network 192.168.1.2 0.0.0.0 area 0

!

ip forward-protocol nd

!         

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

!

end

 

 

R3:

Building configuration...

 

Current configuration : 1340 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R3

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

ip cef

!

!

!

!

no ip domain lookup

ip domain name lab.local

!         

multilink bundle-name authenticated

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

archive   

 log config

  hidekeys

!

!

!

!

!

!

!

interface Loopback0

 ip address 172.16.4.1 255.255.255.0

 ip ospf network point-to-point

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 192.168.1.3 255.255.255.0

 encapsulation frame-relay

 ip ospf network broadcast

 ip ospf priority 0

 clock rate 2000000

 frame-relay map ip 192.168.1.1 301 broadcast

 no frame-relay inverse-arp

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/1

 no ip address

 shutdown

 clock rate 2000000

!

router ospf 1

 log-adjacency-changes

 network 172.16.4.1 0.0.0.0 area 0

 network 192.168.1.3 0.0.0.0 area 0

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line aux 0

 exec-timeout 0 0

 privilege level 15

 logging synchronous

line vty 0 4

 login

!

!

end