Skip to main content

 路由器网 > 新闻资讯 >

计算机网络:静态路由

2014-07-16 22:44 浏览:


实验报告
 

一、实验要求

R1到192.168.2.0/24和192.168.23.0/24的路由只经过R2;

R2到192.168.1.0/24和192.168.13.0/24的路由只经过R1;

R3到192.168.1.0/24的路由只经过R1;

R3到192.168.2.0/24的路由只经过R2;

R3到192.168.12.0/24的路由经过R1或R2做负载均衡

在R3和R4之间配置浮动路由,实现路由备份

在R1、R2、R3配置到10.1.1.0/24的静态路由

R4配置默认路由

二、实验拓扑

 

三、实验步骤

1、按照拓扑配置路由器各个端口IP地址,PC机IP地址

1)R1上配置如下:

interface FastEthernet0/0

ip address 192.168.1.254 255.255.255.0

!

interface FastEthernet0/1

ip address 192.168.13.1 255.255.255.0

!

interface FastEthernet1/0

ip address 192.168.12.1 255.255.255.0

!

2)R2上配置如下:

interface FastEthernet0/0

ip address 192.168.2.254 255.255.255.0

!

interface FastEthernet0/1

ip address 192.168.23.1 255.255.255.0

!

interface FastEthernet1/0

ip address 192.168.12.2 255.255.255.0

!

3)R3上配置如下:

interface FastEthernet0/0

ip address 192.168.13.2 255.255.255.0

!

interface FastEthernet0/1

ip address 192.168.23.2 255.255.255.0

!

interface Serial1/0

ip address 192.168.34.1 255.255.255.0

!

interface Serial1/1

ip address 192.168.43.1 255.255.255.0

!

4)R4上配置如下:

interface FastEthernet0/0

ip address 10.1.1.254 255.255.255.0

!

interface Serial1/0

ip address 192.168.34.2 255.255.255.0

clock rate 128000

!

interface Serial1/1

ip address 192.168.43.2 255.255.255.0

clock rate 128000

!

2、在R1上配置到192.168.2.0/24和192.168.23.0/24的静态路由

R1(config)#ip route 192.168.2.0 255.255.255.0 192.168.12.2

R1(config)#ip route 192.168.23.0 255.255.255.0 192.168.12.2

配置到10.1.1.0/24的静态路由

R1(config)#ip route 10.1.1.0 255.255.255.0 f0/1

3、在R2上配置到192.168.1.0/24和192.168.13.0/24的静态路由

R2(config)#ip route 192.168.1.0 255.255.255.0 192.168.12.1

R2(config)#ip route 192.168.13.0 255.255.255.0 192.168.12.1

配置到10.1.1.0/24的静态路由

R2(config)#ip route 10.1.1.0 255.255.255.0 f0/1

4、在R3上配置到192.168.1.0/24和192.168.2.0/24的静态路由

R3(config)#ip route 192.168.1.0 255.255.255.0 192.168.13.1

R3(config)#ip route 192.168.2.0 255.255.255.0 192.168.23.1

5、在R3上配置到192.168.12.0/24的静态路由,做负载均衡

R3(config)#ip rou 192.168.12.0 255.255.255.0 f0/0

R3(config)#ip rou 192.168.12.0 255.255.255.0 f0/1

6、在R3和R4之间配置浮动路由,R4采用默认路由

R3(config)#ip route 10.1.1.0 255.255.255.0 Serial1/0

R3(config)#ip route 10.1.1.0 255.255.255.0 Serial1/1 50

R4(config)#ip route 0.0.0.0 0.0.0.0 Serial1/0

R4(config)#ip route 0.0.0.0 0.0.0.0 Serial1/1 50

四、验证结果

1、全网互通

 

观察R1路由表,R1到192.168.2.0/24和192.168.23.0/24的路由只经过R2

 

观察R2路由表,R2到192.168.1.0/24和192.168.13.0/24的路由只经过R1

 

观察R3路由表,R3到192.168.1.0/24的路由只经过R1,R3到192.168.2.0/24的路由只经过R2,R3到192.168.12.0/24的路由经过R1或R2做了负载均衡

 

2、验证在R3和R4之间配置的浮动路由

未关闭R4的s1/0口时,pc2能ping通pc3,R3、R4路由表如下:

R3路由表

 

R4路由表

 

关闭R4的s1/0口时,pc2依然能ping通pc3,R3、R4路由表如下:

R3路由表

 

R4路由表