Skip to main content

 路由器网 > 新闻资讯 >

通用路由封装(GRE)VPN配置

2014-07-27 21:52 浏览:


本人没有很好的文采,只能直接配置,有不懂的地方,后面可以联系我,在配置当中,我会尽量在配置命令后面加标注。


1、在R1上配置相关的命令
 

  R1(config)#int fa0/0 ---进入以太网fa0/0接口--

  R1(config-if)#ip address 10.1.1.1 255.255.255.0 --配置以太网fa0/0的接口地址--

  R1(config-if)#no shutdown --激活fa0/0接口--

  R1(config)#int fa0/1

  R1(config-if)#ip add 100.1.1.1 255.255.255.0

  R1(config-if)#no shutdown

  R1(config)#ip route 0.0.0.0 0.0.0.0 fa0/1 --默认指向公网ip---

  R3(config)#int fa0/0

  R3(config-if)#ip add 200.1.1.1 255.255.255.0

  R3(config-if)#no shut

  R3(config)#int fa0/1

  R3(config-if)#ip add 192.168.1.1 255.255.255.0

  R3(config-if)#no shut

  R3(config)#ip route 0.0.0.0 0.0.0.0 fa0/0


下面开始配置VPN
 

  R1(config)#interface tunnel 1 --定义一个tunnel 为1的隧道--

  R1(config-if)#ipaddress 1.1.1.1 255.255.255.0 配置虚拟的ip

  R1(config-if)#tunnel source 100.1.1.1 隧道的源端口ip地址

  R1(config-if)#tunnel destination 200.1.1.1 隧道的目标端口ip地址

  R1(config-if)#exit

  R1(config)#ip route 192.168.1.0 255.255.255.0 tunnel 1 指向隧道默认路由

  R3(config)#interface tunnel 3

  R3(config-if)#ipaddress 1.1.1.2 255.255.255.0

  R3(config-if)#tunnel source 200.1.1.1

  R3(config-if)#tunnel destination 100.1.1.1

  R3(config-if)#exit

  R3(config)#ip route 10.1.1.0 255.255.255.0 tunnel 3