Skip to main content

 路由器网 > 新闻资讯 >

cisco路由交换基础综合实验

2014-09-02 20:59 浏览:

 

公司分为总公司和分公司两个公司。

总公司配置

1. 所有交换机之间使用trunk链路,来实现vlan间的通信。

2. 在二层和三层交换机上面部署了VTP域,使用建立vlan的同步

3. 使用生成树控制公司数据的走向,一半的数据是通过SW1走,一般的数据通过SW2走,而且两台设备互为备份,也就是其中一台设备坏掉,另一台还可以继续工作。

4. 使用SHRP技术做了一个网关方面的冗余,在SW1和SW2之间虚拟出来一个网关,PC机都指向这个网关,如果其中的一台设备坏道,另一台设备还继续保证公司的电脑可以上网。

5. 为了实现总公司和分公司直接网络的连接,决定是使用专线将两个公司连接起来,两个公司之间使用OSPF动态路由的形式访问。

6. 在总公司的SW1上面,拉一根线出来,接外网网络,使用NAT技术实现公司的上网。

7. 在所有网关设备上面设置远程连接的密码以及console密码实现,设备安全。

 

实验部分

 

Trunk建立

SW1(config)#interface range fastEthernet 0/0 - 1

SW1(config-if-range)#switchport trunk encapsulation dot1q

SW1(config-if-range)#switchport mode trunk

以太网通道建立

SW1(config)#interface range fastEthernet 0/14 - 15

SW1(config-if-range)#channel-group 1 mode on

在以太网通道上面建立trunk

SW1(config)#interface port-channel 1

SW1(config-if)#switchport trunk encapsulation dot1q

SW1(config-if)#switchport mode trunk

以太网通道配置验证

 

Trunk验证

!

interface Port-channel1

switchport mode trunk

!

interface FastEthernet0/0

switchport mode trunk

!

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

interface FastEthernet0/14

switchport mode trunk

channel-group 1 mode on

!

interface FastEthernet0/15

switchport mode trunk

channel-group 1 mode on

!

SW2和SW1 配置一致

SW3和SW4只需要配置交换机直接的trunk即可

为了同步在交换机之间同步vlan的信息,所以要在交换机上面创建VTP的域。

在SW1上面创建一个服务端,在其他交换机上面创建客户端

 

VTP服务器端创建

SW1#vlan database

SW1(vlan)# vtp domain benet

SW1(vlan)#vtp password benet

 

VTP客户端创建

SW2#vlan database

SW2(vlan)#vtp domain benet

SW2(vlan)#vtp password benet

SW2(vlan)#vtp client

 

在交换机上面设置两个vlan vlan10vlan20

SW1#vlan database

SW1(vlan)#vlan 10

SW1(vlan)#vlan 20

 

验证vlan是否建立成功

 

 

验证客户端vlan是否同步成功

 

 

跨vlan通信需要三层交换机开启路由功能

路由功能开启

SW1(config)#ip routing

 

SW1IP地址设置,SW2SW1设置地址方式一样

SW1(config)#interface vlan 10

SW1(config-if)#ip address 192.168.10.1 255.255.255.0

SW1(config-if)#no shutdown

SW1(config)#interface vlan 20

SW1(config-if)#ip address 192.168.20.1 255.255.255.0

SW1(config-if)#no shutdown

 

SW1PVST配置

SW1(config)#spanning-tree vlan 10 root primary

SW1(config)#spanning-tree vlan 20 root secondary

 

SW2PVST配置

SW2(config)#spanning-tree vlan 10 root secondary

SW2(config)#spanning-tree vlan 20 root primary

 

PVST配置验证

 

 

SW2PVST验证

 

 

HSRP配置

SW1vlan10 配置HSRP

SW1(config)#interface vlan 10

SW1(config-if)#standby 10 ip 192.168.10.254

SW1(config-if)#standby 10 priority 150

SW1(config-if)#standby 10 preempt

SW1(config-if)#standby 10 track fastEthernet 0/0 100

SW1(config-if)#standby 10 track fastEthernet 0/2 100

 

SW2上VLAN10 配置HSRP

SW2(config)#interface vlan 10

SW2(config-if)#standby 10 ip 192.168.10.10

SW2(config-if)#standby 10 preempt

 

SW2vlan20 配置SHRP

SW2(config)#interface vlan 20

SW2(config-if)#standby 20 ip 192.168.20.20

SW2(config-if)#standby 20 priority 150

SW2(config-if)#standby 20 preempt

SW2(config-if)#standby 20 track fastEthernet 0/0 100

SW2(config-if)#standby 20 track fastEthernet 0/2 100

SW1上面 VLAN20 配置SHRP

SW1(config)#interface vlan 20

SW1(config-if)#standby 20 ip 192.168.20.20

SW1(config-if)#standby 20 preempt

 

HSRP配置验证
 

SW1上面验证

 

 

SW2上面验证

 

配置OSPF网络,使全网互通

红色区域为骨干区域area0

绿色区域为区域1

青色区域为区域2

***区域为区域3

配置区域之前需要先配置交换机和路由器的接口IP地址,首先要保证接口和接口只要要能够通信才可以配置动态路由。

 

首先查看自己的直连地址网段然后发布出去。

 

 

SW1动态路由配置

SW1(config)#router ospf 1

SW1(config-router)#router-id 1.1.1.1

SW1(config-router)#network 192.168.10.0 0.0.0.255 area 0

SW1(config-router)#network 192.168.20.0 0.0.0.255 area 0

SW1(config-router)#network 192.168.0.0 0.0.0.255 area 0

SW1(config-router)#network 192.168.2.0 0.0.0.255 area 2

 

SW2动态路由配置

SW2(config)#router ospf 1

SW2(config-router)#router-id 2.2.2.2

SW2(config-router)#network 192.168.10.0 0.0.0.255 area 0

SW2(config-router)#network 192.168.20.0 0.0.0.255 area 0

SW2(config-router)#network 192.168.3.0 0.0.0.255 area 0

 

R1动态路由配置

R1(config)#router ospf 1

R1(config-router)#router-id 3.3.3.3

R1(config-router)#network 192.168.0.0 255.255.255.0 area 0

R1(config-router)#network 192.168.3.0 255.255.255.0 area 0

R1(config-router)#network 192.168.1.0 255.255.255.0 area 1

 

R2动态路由配置

R2(config)#router ospf 1

R2(config-router)#router-id 4.4.4.4

R2(config-router)#network 192.168.1.0 255.255.255.0 area 1

R2(config-router)#network 192.168.4.0 255.255.255.0 area 1

 

R3动态路由配置

R3(config)#router ospf 1

R3(config-router)#router-id 5.5.5.5

R3(config-router)#network 192.168.2.0 255.255.255.0 area 2

 

路由表查看
 

特权模式密码设置

SW1(config)#enable password benet

 

Console密码设置

SW1(config)#line console 0

SW1(config-line)#password cisco

SW1(config-line)#login

 

VTY密码设置

SW1(config)#line vty 0 4

SW1(config-line)#password benet

SW1(config-line)#login

 

设置密码密文显示

SW1(config)#service password-encryption